LUKS on GNOME

Erik, it just works for me. I have LUKS on a partition on a USB stick. When inserted I get a dialogue box asking for the LUKS password. I had to configure hal a little to give the desktop icon a good name:

<device>
  <match key="volume.uuid" string="d23647f8-22be-4a8c-86f8-8f59975e9e61">
    <merge key="volume.label" type="string">StickSecret</merge>
  </match>
</device>
Share

2 Comments

  1. Can you insert your stick and try to find out which application is actually displaying the password prompt? Maybe it needs a certain package I don’t have installed and falls back to the text mode prompt. Try doing a “pstree” to see children of pmount or so maybe? Thanks!

    As for the volume label, did you try using tune2fs to label your volume directly?

  2. Hmm, tried doing that. pmount isn’t running while I enter the password. I did find an article on encryption support in HAL which leads me to believe that pmount isn’t involved in the password collecting at all.

    Yes, I tried using tune2fs to set the label, but it didn’t work. The LUKS device is mapped onto /dev/mapper/_dev_sdb1, then that device is mounted by pmount. Somewhere in that indirection my volume label got lost, forcing me to do the hal thing.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>